Requirements

Hardware

Upswift agent works on the next processors' architectures: x86, x86_64, armv6, armv7, and armv8.

Software

  1. Upswift agent works on Linux based operating systems. Therefore, your edge-device must run Linux-based OS (Yocto based, Debian, Ubuntu, etc).

  2. Systemd/SysV (init.d) service manager must be installed.

  3. To connect devices running other Operating Systems such as RTOS, Windows CE, Android, please refer to our Agent API.

‚Äč